Dell Wyse ThinOS 8 und Citrix Storefront 2.0 – UPDATE: 07.10.2013

Im produktiven Einsatz habe ich momentan quasi zu 100% folgende Produkte:

Die User greifen dabei immer auf einen Hosted Shared Desktop zu, der vom ThinClient nach dem Anmelden automatisch gestartet wird. Dieses Konstrukt wird in der Form auch noch eine ganze Weile produktiv bleiben, weil es stabil und zuverlässig läuft. (Einen Artikel wie ich die oben genannte Umgebung auf ThinOS 8 bringe, wird es später geben.)

Trotzdem hat es mich interessiert, wie ThinOS 8 mit dem neuen Storefront 2.0 zusammenarbeitet, also ich habe folgendes getestet:

  • XenApp 6.5 HRP02
  • Storefront 2.0
  • Dell Wyse C10LE mit Firmware ThinOS 8.0_037 (21.06.2013)

Dazu habe ich zuerst meine interne Testfarm, die bisher mit Webinterface läuft, um einen Storefront 2.0 Server auf Windows Server 2008 R2 ergänzt. Dazu habe ich mich an folgendem sehr guten CTX Artikel von Citrix orientiert:

  • http://support.citrix.com/article/CTX133185 – Citrix StoreFront – Implementation Guide

Anschließend, habe ich die “wnos.ini” wie folgt abgeändert und das entsprechende Zertifikat unter
…\wyse\WNOS\cacerts\Test_CA.crt
abgelegt.

[xml]AddCertificate=Test_CA.crt
IcaBrowsing=HTTP
PnliteServer=https://storefront.techlab.loc/Citrix/Techlab/PNAgent/config.xml ReconnectAtLogon=2 ReconnectFromButton=2 AutoConnectList="*Desktop*" DefaultSettings=XenDesktop
[/xml]

Leider musste ich dann feststellen, dass der Autostart des Published Desktop nicht mehr geht. Nach dem Anmelden wird mir die Anwendungsliste präsentiert, die die User sonst nie zu sehen bekamen. Erfreulicherweise kann ich von dort trotzdem noch erfolgreich meine Sitzung starten und arbeiten.
Wenn ich die Sitzung abbreche und mich erneut Anmelde, gibt es außerdem keinen automatischen Reconnect. Ich sehe wieder nur die Liste der Anwendungen. Verbinde ich mich wiederum von Hand mit dem Desktop, lande ich auch in meiner getrennten Sitzung.

Fassen wir zusammen: Die grundsätzliche Funktionalität ist vorhanden, aber ein für mich essentielles Feature fehlt. Somit bleibt Storefront für mich (bis auf weiteres) nur ein Spielzeug ohne wirklichen praktischen nutzen.

UPDATE: Ich habe Feedback von Dell Wyse dazu erhalten, nachdem ich den Fehler gemeldet habe. Der Bug wurde bestätigt und wird im nächsten Release von ThinOS 8 behoben. Zu rechnen ist damit im 4. Quartal 2013. Ich werde das Ganze dann erneut testen und den Artikel anschließend aktualisieren.

Author: Marco

Gelernter Fachinformatiker für Systemintegration (2010) CCA für XenServer 5.0 (2009) CCA für XenApp 5.0 (2011) CCA für XenApp 6.5 (2013) CCAA für XenApp 6.5 (2013) CCA für XenDesktop 5 (2013) Dell Wyse ThinOS Select Techniker (2011) Igel Authorized Partner (2009-2014) Intensivkurs “Group Policy Administration” Windows 7, 8.x sowie Windows Server 2008-R2 / 2012-R2 bei NT Systems, Dipl.-Ing. T. Pham (2014) Zu Gast auf der E2EVC Virtualization Conference in Berlin (2015) Zu Gast auf der Citrix Technology Exchange in Berlin (2016) Citrix Certified Associate – Networking (CCA – N) (2016) Citrix Certified Professional – Networking (CCP – N) (2017)

2 thoughts on “Dell Wyse ThinOS 8 und Citrix Storefront 2.0 – UPDATE: 07.10.2013”

  1. As for the c10le is this also going to work for older devices like the s10 from wyse?
    We would like to test newer xenapp 7.5. As citrix moved away from ima is, have they also excluded these thin clients as working devices?

    Regards mark

    1. Hello Mark,
      >> As for the c10le is this also going to work for older devices like the s10 from wyse?
      We have no S10 Clients, but I’m sure that this is only dependent from the firmware version.

      >> We would like to test newer xenapp 7.5. As citrix moved away from ima is, have they also excluded these thin clients as working devices?
      This has nothing to do with the switch from IMA to FMA. The question if the ThinClient works, depends (nearly) only on the Webinterface / Storefront implementation. After all, it is still ICA Traffic that the client has to display. This has not changed because of FMA.
      We have tested this here in many Ways.

      XenApp 6.5 Farm (and XenApp 7.5 Farm (only tested a bit in our lab, no production use)):
      Webinterface 5.4 – ThinOS 7 -> Works
      Webinterface 5.4 – ThinOS 8 -> Works
      Storefront 2.5 (legacy PNagent URL) – ThinOS 7 -> Works (AutoConnectList=”*Desktop*” didn’t work. Although we could start every app manually)
      Storefront 2.5 (native) – ThinOS 7 -> Doesn’t work
      Storefront 2.5 (native) – ThinOS 8 -> Works. But I really do not like to use it at all.

      Hope this helps.

Leave a Reply

Your email address will not be published. Required fields are marked *